5

I just recently upgraded from Bitcoin client 0.3.? to 0.6.1-beta for Mac.

In the old version I had the option of generating coins; I don't see that option here. Activity Monitor shows Bitcoin-Qt consistently using >95% CPU. As I understand it, CPU mining is essentially useless, so I'd like to turn it off, but still have the option to receive coins if I'm paid by someone.

Is this possible?

  • 5
    There was a very recent bug report about high CPU usage in 0.6.1 on OSX. If you're hit by the same problem, it's not coin generation that causes it, but a thread synchronisation bug. – Pieter Wuille May 9 '12 at 2:32
  • Interesting; I will look into that when I get home. – Thunder Rabbit May 9 '12 at 6:44
  • 2
    0.6.2.2 was released, which fixes the 100% issue. – Pieter Wuille May 11 '12 at 23:48
5

As far as I know the option is off by default in the new versions. To make sure you can add a line

gen=0

to your bitcoin.conf file.

    0

    The SourceForge link currently on bitcoin.org points to the 0.6.2 version. Surgically insert ".2" to get a link to the fixed version:

    http://sourceforge.net/projects/bitcoin/files/Bitcoin/bitcoin-0.6.2.2/

    Do not use this link if a newer release is available!

      Your Answer

      By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

      Not the answer you're looking for? Browse other questions tagged or ask your own question.